安装了一个CentOS5的系统。运行一个python的脚本出错,结果发现python还是2.4版本,果断升级python的版本到2.7去。

要升级到2.7或者其他版本需要下载源码包自己编译安装2.7版本下载地址

http://www.python.org/ftp/python/2.7/Python-2.7.tar.bz2

在root权限下执行以下命令

tar jfvx Python-2.7.tar.bz2
./configure
make all
make install
make clean
make distclean

查看是否生效

python -V
Python 2.7

修改软链接

mv /usr/bin/python /usr/bin/python-bak
ln -s /usr/local/bin/python2.7 /usr/bin/python

升级安装好以后yum会无法使用,因为yum使用的是2.4版本的,所以要修改yum的配置文件以便能够识别2.4版本下的python
vim /usr/bin/yum

将文件头部的
#!/usr/bin/python

改成

#!/usr/bin/python2.4

就可以继续使用yum了

Comments Closed